Clinic HQ - Service Disruption Due to Azure Outage – Incident details

All systems operational

Service Disruption Due to Azure Outage

Resolved
Major outage
Started 4 days agoLasted about 3 hours

Affected

Main Application

Major outage from 4:02 PM to 5:34 PM, Degraded performance from 5:34 PM to 6:43 PM

Client Portal

Major outage from 4:02 PM to 5:34 PM, Degraded performance from 5:34 PM to 6:43 PM

Chat

Operational from 4:02 PM to 6:43 PM

Updates
  • Resolved
    Resolved

    Our temporary workaround has successfully stabilized Clinic HQ, and most services are now operating normally.

    However, the Chat remains affected due to the ongoing Azure outage, which continues to impact networking and DNS services. This issue is external and will be fully resolved once Azure restores normal functionality.

    We will continue monitoring system performance and provide updates as Azure progresses with their recovery efforts.

    Thank you for your patience and understanding as we work through this.

  • Update
    Update

    We have confirmed that Microsoft Azure is experiencing an ongoing outage, likely due to a networking issue affecting their DNS services.

    To mitigate the impact, our engineering team is implementing a temporary workaround by circumventing Azure’s DNS servers and attempting to serve Clinic HQ services directly.

    This mitigation effort is currently in progress, and we are closely monitoring performance and stability. While the underlying issue remains within Azure’s infrastructure, we are doing everything possible to minimize service disruption for our users.

    Further updates will be provided as the situation evolves.

    Thank you for your patience and understanding.

  • Monitoring
    Monitoring

    We have confirmed that Microsoft Azure is experiencing an ongoing outage, most likely related to a networking issue. This is currently impacting our services.

    Our team is actively monitoring the situation and working closely with Azure for updates. As the issue originates from Azure’s infrastructure, resolution is outside of our direct control.

    We will continue to provide updates as more information becomes available.

    Thank you for your continued patience.

  • Investigating
    Investigating

    We are currently experiencing service disruptions due to an ongoing issue with our cloud service provider, Microsoft Azure. Our engineering team is actively investigating the impact and working closely with Azure to understand the scope and restore normal operations as quickly as possible.

    We will provide updates as more information becomes available.

    Thank you for your patience and understanding.