Clinic HQ - MxMerchant Issue – Incident details
Report an issue
Get updates
Email
Slack
Microsoft Teams
Report an issue
Get updates
Language
All systems operational
MxMerchant Issue
Resolved
Major outage
Started 11 days ago
Lasted about 2 hours
Affected
MX Merchant → API
Major outage from 5:01 PM to 6:47 PM
Updates
Resolved
March 31, 2026 at 6:47 PM
Resolved
March 31, 2026 at 6:47 PM
This incident has been resolved.
Identified
March 31, 2026 at 5:01 PM
Identified
March 31, 2026 at 5:01 PM
We are continuing to work on a fix for this incident.