Clinic HQ - Slowness detected – Incident details

All systems operational

Slowness detected

Resolved
Major outage
Started about 1 month agoLasted about 3 hours

Affected

Main Application

Degraded performance from 4:01 PM to 7:12 PM

Client Portal

Degraded performance from 4:01 PM to 7:12 PM

Updates
  • Resolved
    Resolved

    Earlier today, customers experienced intermittent slowdowns and occasional timeouts during appointment checkout, specifically when removing services from an appointment. The delay on those operations queued up other unrelated requests, which amplified the impact across the app. Engineering identified and mitigated the root cause, and all systems have returned to normal.

  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Identified
    Identified

    We are working on a fix for this incident.